NodeMCU mit Arduino IDE programmieren

Vorbereitungen Der NodeMCU lässt sich am einfachsten mit der Arduino IDE flashen. Die Anleitung zeigt Ihnen, wie. Sollten Sie die Arduino IDE noch nicht auf Ihrem PC installiert haben, so können Sie diese hier kostenlos herunterladen. Nach erfolgreicher Installation starten Sie Arduino IDE und öffnen Sie die “Voreinstellungen” über den Reiter “Datei”. Anschließend fügen Sie…

Image Description

Vorbereitungen

Der NodeMCU lässt sich am einfachsten mit der Arduino IDE flashen. Die Anleitung zeigt Ihnen, wie.

Sollten Sie die Arduino IDE noch nicht auf Ihrem PC installiert haben, so können Sie diese hier kostenlos herunterladen.

Nach erfolgreicher Installation starten Sie Arduino IDE und öffnen Sie die “Voreinstellungen” über den Reiter “Datei”.

Voreinstellungen in Arduino IDE öffnen

Anschließend fügen Sie folgenden Pfad in die Textbox bei “Zusätzliche Boardverwalter-URLs” ein. Sie können mehrere URLs mit einem Komma trennen.

http://arduino.esp8266.com/stable/package_esp8266com_index.json
URL eingeben

Nun öffnen Sie die “Boardverwaltung” unter “Werkzeuge => Board => Boardverwalter…”

Arduino IDE Boardverwaltung öffnen

In die Suchleiste “esp8266” eingeben und das Ergebnis installieren.

Wählen Sie abschließend noch das richtige Board aus.

Bibliotheken installieren

Blynk Library for Arduino installieren

Sollte euer Quellcode obige Bibliothek nicht benötigen, so können die folgenden Schritte übersprungen werden.

Download

Ihr könnt die Bibliothek hier kostenfrei herunterladen.

Installation

Entpackt das heruntergeladene Archiv. Dort findet Ihr zwei Ordner. Beide müssen in das Sketchbook-Verzeichnis eurer Arduino IDE Installation kopiert werden. Ihr findet den Pfad unter “Datei => Voreinstellungen =>
Sketchbook- Speicherort”

Kopiert beide Ordner aus dem Archiv in diesen
Sketchbook-Ordner.

ihr_sketchbook_ordner/libraries/Blynk
ihr_sketchbook_ordner/libraries/BlynkESP8266_Lib
...
ihr_sketchbook_ordner/tools/BlynkUpdater
ihr_sketchbook_ordner/tools/BlynkUsbScript
...

Eine detaillierte Anleitung finden Sie hier.

Flashen

Nun kann euer Projekt über “Sketch -> Kompelieren und Hochladen” auf den NodeMCU geflasht werden.

Schlagwörter: ,

War dieser Artikel hilfreich für Sie?

Ja Nein